2

On the home page instead of displaying blocks displays:

We're sorry, an error has occurred while generating this content.

Any solution?

in debug.log

[2018-04-02 08:31:45] main.CRITICAL: Cannot read contents from file "/home/fsg/domains/wearon.pl/public_html/pub/static/frontend/Mgs/claue/cs_CZ/mage/requirejs/mixins.min.js" Warning!file_get_contents(/home/fsg/domains/wearon.pl/public_html/pub/static/frontend/Mgs/claue/cs_CZ/mage/requirejs/mixins.min.js): failed to open stream: No such file or directory {"exception":"[object] (Magento\\Framework\\Exception\\FileSystemException(code: 0): Cannot read contents from file \"/home/fsg/domains/wearon.pl/public_html/pub/static/frontend/Mgs/claue/cs_CZ/mage/requirejs/mixins.min.js\" Warning!file_get_contents(/home/fsg/domains/wearon.pl/public_html/pub/static/frontend/Mgs/claue/cs_CZ/mage/requirejs/mixins.min.js): failed to open stream: No such file or directory at /home/fsg/domains/wearon.pl/public_html/vendor/magento/framework/Filesystem/Driver/File.php:149)"} []
[2018-04-02 08:31:50] main.CRITICAL: Cannot read contents from file "/home/fsg/domains/wearon.pl/public_html/pub/static/frontend/Mgs/claue/en_US/mage/requirejs/mixins.min.js" Warning!file_get_contents(/home/fsg/domains/wearon.pl/public_html/pub/static/frontend/Mgs/claue/en_US/mage/requirejs/mixins.min.js): failed to open stream: No such file or directory {"exception":"[object] (Magento\\Framework\\Exception\\FileSystemException(code: 0): Cannot read contents from file \"/home/fsg/domains/wearon.pl/public_html/pub/static/frontend/Mgs/claue/en_US/mage/requirejs/mixins.min.js\" Warning!file_get_contents(/home/fsg/domains/wearon.pl/public_html/pub/static/frontend/Mgs/claue/en_US/mage/requirejs/mixins.min.js): failed to open stream: No such file or directory at /home/fsg/domains/wearon.pl/public_html/vendor/magento/framework/Filesystem/Driver/File.php:149)"} []
1
  • 1
    cms home page check any custom block call in page Commented Mar 31, 2018 at 16:45

2 Answers 2

4

Check your error logs what error it says some time this error occurs when there is change in db. run php bin/magento setup:upgrade and php bin/magento cache:flush

enable / set developer mode ( if not already ) to set developer mode in your htaccess file. Uncomment

SetEnv MAGE_MODE developer

or / also you can run below command in CLI :

php ./bin/magento deploy:mode:set developer

So you can see which section / block is causing the issue. Hope above steps will help to figure out the issue and help you to fix it.

7
  • I have checked log file and update my topic.
    – Sylvester
    Commented Apr 2, 2018 at 8:34
  • have you deployed static content after installation of extension ? ( first delete your pub/static/frontend and var/view_processed/pub folder content and then try again). Commented Apr 2, 2018 at 8:36
  • I have migrate magento on second server and after migrate display this error. I have try delete pub/static.. etc and deployed again but still no work.
    – Sylvester
    Commented Apr 2, 2018 at 9:10
  • disable "Mgs" module and then try again. Commented Apr 2, 2018 at 9:15
  • MGS created the template and its all modules magento working.
    – Sylvester
    Commented Apr 2, 2018 at 9:18
0

In magento 2.3.3 version

you can add the 

'static_content_on_demand_in_production' => 1,

 

in evn.php file after date.

Its working perfect.

See below link 

https://github.com/magento/magento2/issues/6426

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.