I don't understand why the Add Category button isn't showing up in my store. Does anyone have a solution for this?

Index and cache are normal. Every other button including the upload button works normally.


  • Please switch your Default store View to All Store Views. after you can add a category. Mar 30, 2018 at 10:00
  • It didn't work. Any other suggestions
    – Daniel
    Mar 30, 2018 at 19:52

4 Answers 4


Please switch your Default store View to All Store Views. after you can add a category.

Please see below screenshot,

enter image description here

  • I have done that but it still doesn't work. Any other suggestion?
    – Daniel
    Mar 30, 2018 at 19:50
  • On which Magento version you work? @Daniel Mar 31, 2018 at 4:08
  • On magento 2.2.1. I really don't know what next to do and I really need a fix fast.
    – Daniel
    Mar 31, 2018 at 6:45
  • Please add screenshot after the change to All Store Views. Mar 31, 2018 at 6:48
  • Screenshot is the same.. Just with a difference in store view name... It is selected to all to view. Atleast I know that much.
    – Daniel
    Mar 31, 2018 at 7:12

Switch Store View to "All Store Views" option

  • Not Working. Switched and Cleared cache also
    – Daniel
    Mar 30, 2018 at 19:51

Well, since this seem like a problem only I had, i just did a simple work-around of upgrading the system with fresh install of latest version.


Same issue, I am facing tried to resolve by debbuging in Magento\Catalog\Block\Adminhtml\Category\Tree::_prepareLayout(). You will get false in first if codition some time. you will get more idea in this file.

May be it will help you to resolve your problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.