1

When applying laygered navigation filter in my Magento 2, In Developer Mode I got this error,

1 exception(s):
Exception #0 (Magento\Framework\Exception\LocalizedException): sorry, something went wrong. You can find out more in the error log

But the problem is that nothing is tracked in whether the Apache error log or the Magento log. So I don't know how to diagnose the issue.

Any ideas on how to debug when seeing errors like this?


Update,

If I turn Production Mode on, the Exception #0 (Magento\Framework\Exception\LocalizedException): error mesesage is gone, and it displays an empty page, but I in developer tools in my browser it says "JavaScript seems to be disabled in your browser".

enter image description here

But I'm sure it's nothing to do with Javascript on my browser. I've tried with different browsers on different computers, I got the same error.

1

You can get this error on two times.

  • When Product collection is called.
  • When Advance Search Collection is called.

On classes

  • Magento\CatalogSearch\Model\ResourceModel\Advanced\Collection.
  • Magento\CatalogSearch\Model\ResourceModel\Fulltext\Collection.

I guess that you have issue on collection call.

I guess that you need to do an indexing.

  • I just did reindexing. I didn't help. Is there a way that I can see the error in log? I wonder why apache error log didn't track anything. I got the error when applying layered navigation in magento. but not all options i selected in the filter give me the error. for example if i use only price in the layered navigation then it's working fine. it's sizes, and some other option that gives errors. – Magento Learner Mar 29 '18 at 3:52
  • I have look further on this issue, and you are right, it is the fulltext search gave the error. it's my 3rd part module that conflicted with Magento's Layered navigation. – Magento Learner Apr 4 '18 at 13:10
  • which extension? – Amit Bera Apr 4 '18 at 13:33
  • It's EaDesign's warehouse inventory module. github.com/EaDesgin/magento2-warehouses/issues/13 I have disabled the fulltext search from this module, then Layered Navigation is working again. – Magento Learner Apr 4 '18 at 13:42
  • @AmitBera i did indexing but still getting this error,i am using that mageplaza layered navigation – sumeet bajaj Feb 6 at 12:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.