0

I have a Magento2 store. I don't want to add the category path into products URLs for that I set “Use Categories Path for Product URLs” as "NO" in magento2 Admin, but It still add the category path to the product URL.

What I already tried.

  1. set “Use Categories Path for Product URLs” as "NO"
  2. Did Reindex
  3. Next I truncate tables url_rewrite and catalog_url_rewrite_product_category
  4. Did reindex
  5. Regenerate products URL

But No results.

0

You must follow in your admin, Store -> Configuration -> Catalog -> Catalog -> Search Engine Optimization -> Use Categories Path for Product URLs, you must change to No, and you have to make sure that in the Website and Store View is No.

After that, you must reindex and refresh the cache.

  • I have already done this. But nothing changed. – Suman Pradhan Mar 26 '18 at 11:31
  • You have to make sure that on the Website and Store View is No – St3phan Mar 26 '18 at 11:33
  • I tested and it works. – St3phan Mar 26 '18 at 11:35
  • Yes, In default it is NO and in website it is set as " Use Default" which is NO and In store view it is set as "Use Website" which is also set as NO. – Suman Pradhan Mar 26 '18 at 11:36
  • What should I do except these steps? is there anything to check? – Suman Pradhan Mar 26 '18 at 11:37
-2

Make sure that the category is disconnected from the Аnchor. Display Settings > Anchor NO

  • If set Display Settings > Anchor NO, layered navigation's attributes on left sidebar will not displayed as I guess. – Suman Pradhan Mar 26 '18 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.