1

I am using Magento 1.9 and using the theme elegance . I have installed the theme manually from extracting the files in root directory and by following the instructions in the site domain. But my theme isn't loading correctly and if I check in the developer's console. I see the theme source file is just skin/frontend/ instead of skin/frontend/luxury/. All the CSS and page contens are also not working properly. You can check here - http://stuffkart.com

Also, some js and css files are loading from skin/frontend/base/

I am a bit new to Magento. Searched a lot, but can't find anything that could've solved it.

0

Go into your admin under System -> Config -> Design and under the Package and Theme section make sure you have the theme defined. In your case i'm not 100% when this needs to be set to, as i don't know the directory structure that was installed and i can't find the documentation on the theme forest link you posted.

If you have a path like skin/frontend/theme/name then theme will need to be in the Package area (in the pic i have rwd there, so this would replace) and name would in under Theme in all the areas (if there are not translations you can leave that blank).

If you have a path like skin/frontend/default/theme then you want to leave Package blank and only place theme in the Theme section.

enter image description here

As an FYI, the reason some of the files are trying to read from skin/frontend/base/ is the fallback system Magento uses. If a file is being called from skin/frontend/theme/name/js/somefile.js and that file is not found in that directory, Magento will automatically look in the next package down from it to see if it's there, with the last package being base. So there is no call to a file in the base folder, but since the fallback sees base as the last place to check, the error sent to the browser is for a file with that call. This can get confusing at first as you might be tempted to look for that file in base, but the theme settings will tell you the truth of where files are being drawn from on a Magento install.

| improve this answer | |
  • My directory is skin/frontend/luxury/default/ , so this is how my theme settings looks now - i.imgur.com/NuiBbyk.png , but it's still not working. Also, if the theme is missing correspondent files and going into fallback. Should I report this to the theme company? It's a premium theme, what else can I do to fix the missing files issue? – Tayeaba Mila Mar 26 '18 at 13:56
  • That is the correct way to set up the theme, but i just looked at your site and your path is http://stuffkart.com/magento/skin/frontend/base/default/favicon.ico so i think you have the wrong settings in your base url. Under the base url you should see this {{unsecure_base_url}}skin/ and this {{secure_base_url}}skin/. If that is correct, you should check to make sure your url in those fields is not http://stuffkart.com/magento/. – circlesix Mar 26 '18 at 15:21
  • 1
    Yes, they were set at that setting. Fortunately, I reinstalled the theme and it's working now. I am not quite sure why, cause I have reinstalled it before also. But it seems to be working now. Thanks a lot for your assistance, got some knowledge for future reference. ^_^ – Tayeaba Mila Mar 26 '18 at 17:44
  • good to hear it's working now! – circlesix Mar 26 '18 at 19:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.