3

For the homepage of a magento shop I use the following code in the plain text editor:

<p>Some text...</p>
{{block type="catalog/product_list" name="home.catalog.product.list"
    alias="products_homepage" template="catalog/product/list.phtml"}}

When I save this, magento switches to the WYSIWYG editor. When I change back to the plain editor, I see that magento has inserted some code:

<p>Some text...</p>
<p>{{block type="catalog/product_list" name="home.catalog.product.list"
    alias="products_homepage" template="catalog/product/list.phtml"}}</p>

How can I prevent this <p> tag to be inserted. Do I need to remove this editor, or can I use another one?

  • 1
    you could just disable the WYSIWYG-Editor by default, so magento will not override your changes if you reopen the page/block. Admin > System > Configuration > Content Management > WYSIWYG Options – Dopamedia Jun 2 '14 at 12:33
1

I usually find disabling it all together is the best way to go. If that's an option you can find the settings here:

System > Configuration > Content Management > WYSIWYG Options
1

Be careful In Magento 2.1.7 Configuration has moved to Stores section. This is the new link : Store > Configuration > Content Management > WYSIWYG Options

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.