0

If we buy a paid theme from a 3rd party which is 2.2.x compatible, and when magento 2.3 gets release, will we still be able to upgrade to 2.3 backend even if the 3rd party company does not provide an update?

1

Short answer NO. If you don't ready to fix issues, which can appear after an upgrade.

Long answer Magento provides versioning with 3 digits (example 2.2.3) :

  • 2.*.* (first digit) - is marketing version which is mostly used for highlighting that this is brand new instead of Magento1 (aka Magento) and this digit will not be changed a long time
  • 2.2.* (second digit) - major releases, this digit will be changed when Magento released some new features and updates that breaks backward compatibility, so - this is your case
  • 2.2.3 (third digit) - is a minor release, these releases preserve backward compatibility.

So, during the last years Magento core team provided service contracts and marked it as API for developers, so if your theme vendor created all theme according to the Magento best practices - even after major release you can be ok without theme updates.

But real life shows that this will be a miracle...

UPDATE from comments below:

The better way will be to find several good themes from very strong market players like Template Monster (this is not ad. TMonster doesn't pay me) and etc and contact to the vendor directly asking for future updates of the particular theme. You can also install magento2.3develop from github and try this theme on dev version. This is no guarantee that if it will be ok on 2.3dev then it will be ok on the final release, but this will show you if theme already not fit to 2.3

  • Thanks for the detailed answer. Is it better to go with luma and customize to our needs then? – Rajesh Mar 20 '18 at 22:37
  • @Rajesh the answer is very difficult. I think the better way will be find several good themes from very strong market players like Template Monster(this is not ad. TMonster doesn't pay me) and etc and contact to vendor directly asking for future updates of particular theme. You can also install magento2.3dev from github and try this theme on dev version. This is no guarantee that if it will be ok on 2.3dev then it will be ok on final release, but this will show you if theme already not fit to 2.3 – Stepan Furman Mar 20 '18 at 23:28
  • @Rajesh you know what to do. Check my answer as answer and vote up;) You are welcome. – Stepan Furman Mar 20 '18 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.