0

I uninstalled a module with command:

magento module:disable Dotdigitalgroup_Email

and once I run:

magento setup:di:compile

I get this error message:

Warning: array_replace_recursive(): Argument #1 is not an array in /home/playsports/public_html/magento2/vendor/magento/framework/App/Deploy
  mentConfig/Writer.php on line 135

I'm on Centos, PHP7.1

enter image description here

  • I also have an error when I run magento setup:upgrade (as seen in the picture) I am not certain they relate so I just want to figure out this one first as it won't let me get my store back up and I need to compile... – Mike Mar 20 '18 at 14:15
0

OK for anyone else who ever runs into this issue the problem was that the env.php file got corrupted somehow when disabling the module (in /app/etc). I did not have a backup, so I found one available online: https://github.com/emizentech/magento2/blob/master/app/etc/env.php.sample I used that to build it again and once complete I copied it into the /app/etc directory.

I still think this is a core issue as somehow this file got overwritten, and it shouldn't have... but anyhow.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.