0

I followed the directions here and installed via composer. https://github.com/mageplaza/magento-2-smtp

Install via composer (recommend) Run the following command in Magento 2 root folder:

composer require mageplaza/module-smtp
php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy

It installed two folders in /vendor/mageplaza/

module-core and module-smtp

/vendor/mageplaza/module-smtp/composer.json

    {
  "name": "mageplaza/module-smtp",
  "description": "SMTP Extension for Magento 2 helps the owner of store simply install SMTP (Simple Mail Transfer Protocol) server which transmits the messages into codes or numbers",
  "require": {
    "mageplaza/module-core": "^1.3.10"
  },
  "type": "magento2-module",
  "version": "1.1.3",
  "license": "proprietary",
  "authors": [
    {
      "name": "Mageplaza",
      "email": "support@mageplaza.com",
      "homepage": "https://www.mageplaza.com",
      "role": "Technical Support"
    }
  ],
  "minimum-stability": "dev",
  "keywords": [
    "magento 2",
    "magento 2 smtp",
    "magento smtp",
    "mageplaza",
    "smtp",
    "email settings",
    "gmail smtp"
  ],
  "autoload": {
    "files": [
      "registration.php"
    ],
    "psr-4": {
      "Mageplaza\\Smtp\\": ""
    }
  }
}

/vendor/mageplaza/module-smtp/registration.php

<?php
/**
 * Mageplaza
 *
 * NOTICE OF LICENSE
 *
 * This source file is subject to the mageplaza.com license that is
 * available through the world-wide-web at this URL:
 * https://www.mageplaza.com/LICENSE.txt
 *
 * DISCLAIMER
 *
 * Do not edit or add to this file if you wish to upgrade this extension to newer
 * version in the future.
 *
 * @category    Mageplaza
 * @package     Mageplaza_Smtp
 * @copyright   Copyright (c) 2017-2018 Mageplaza (https://www.mageplaza.com/)
 * @license     https://www.mageplaza.com/LICENSE.txt
 */

\Magento\Framework\Component\ComponentRegistrar::register(
    \Magento\Framework\Component\ComponentRegistrar::MODULE,
    'Mageplaza_Smtp',
    __DIR__
);

/vendor/mageplaza/module-smtp/etc/module.xml

<?xml version="1.0"?>
<!--
/**
 * Mageplaza
 *
 * NOTICE OF LICENSE
 *
 * This source file is subject to the mageplaza.com license that is
 * available through the world-wide-web at this URL:
 * https://www.mageplaza.com/LICENSE.txt
 *
 * DISCLAIMER
 *
 * Do not edit or add to this file if you wish to upgrade this extension to newer
 * version in the future.
 *
 * @category    Mageplaza
 * @package     Mageplaza_Smtp
 * @copyright   Copyright (c) 2017-2018 Mageplaza (https://www.mageplaza.com/)
 * @license     https://www.mageplaza.com/LICENSE.txt
 */
-->
<config xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="urn:magento:framework:Module/etc/module.xsd">
    <module name="Mageplaza_Smtp" setup_version="1.1.0">
        <sequence>
            <module name="Mageplaza_Core"/>
        </sequence>
    </module>
</config>

It's not appearing in admin like so: enter image description here

  • bin/magento module:status (it's enabled)
  • app/etc/config.php (double checked it's in there marked with 1)
  • caching is turned off
  • developer mode is turned on
  • bin/magento cache:clean
  • bin/magento cache:flush
  • redis-cli flushall

I can't get this module to show up in admin. Any ideas?

  • First check compatibility with your Magento version – Rishabh Rk Rai Mar 15 '18 at 17:35
  • try run: php bin/magento setup:di:compile – Wise Ltd. Mar 15 '18 at 23:17
0

Let's check the following to make sure it enables.

Checklist:

  • Install Mageplaza_Core
  • Install correct Magento installation
  • Go to correct admin URL
  • Flush cache, disable other cache types
  • Check it enable: in app/etc/config.php and bin/magento module:status

The Mageplaza SMTP module menu: - Mageplaza > SMTP - Stores > Mageplaza SMTP

  • Sorry @Say Truth, i should of closed this a while ago. – Supplement May 30 '18 at 19:28
0

It ended up installing it in the wrong directory. It should of placed it vendor but it placed it in app/code/

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.