0

I have an issue with my Index Management job stuck in "Processing". I have read about it and found out that I can check if the reindex process is running by checking in MySQL, which I did. It is showing that the process is "working". I can also do a SHOW FULL PROCESSLIST command and see if there are any inserts or delete commands against the catalog_product_index_eav table, which I have done and there is indeed a process running for the last 2 days... So it appears that the process is still running but it has been like this for 2 days... However, I am doing random: SELECT COUNT(entity_id) AS total FROM catalog_product_index_eav; statements on the database and the number is not changing.

My questions are:

  • Is it normal for this process to take so long? We have roughly 10,000 products in the store.
  • Can I stop this process, as it's preventing me from doing any other reindex job... and if so, would this have a negative affect?
  • What would happen if I delete the files in /var/locks while the process is running? I guess it would allow 2 index processes to run at the same time?

Thanks

  • Did you tried indexing by command line ? – Dhaval Solanki Mar 15 '18 at 11:48
  • I didn't, I am worried about doing this as my knowledge of Magento is limited and this is a live store. Could trying to run via command line cause any unwanted affects on my store or is this something I can try and not worry about breaking everything? – Caramex Mar 15 '18 at 12:03
  • Just an update, there is no longer any selects or deletes running on the catalog_product_index_eav table, however when I do a "select * from index_process" on the magento db, it's showing me that the catalog_product_attribute is in status "working"... – Caramex Mar 15 '18 at 12:15
  • actually indexing might be in process that's why you are getting that error , And if you do indexing with command line then just take care properly and indexing will be done – Dhaval Solanki Mar 15 '18 at 12:18
  • magento.stackexchange.com/a/162169/49821 You may try this once – Dhaval Solanki Mar 15 '18 at 12:30
1

Would suggest to stop the indexing and restart it. Go to project root directory from Command Line / Terminal and then enter below commands.

You can reset the indexing process by command

php bin/magento indexer:reset

After that reindex again,

php bin/magento indexer:reindex
0

I resolved this issue in the end by killing the MySQL query that was running. I then changed the index jobs to "Manual Start" so that they don't run automatically.

I increased the amount of memory that was allocated to PHP and I am now able to run the indexes manually (via ssh), however, the Category Search Index has started to throw errors:

PHP Fatal error: Allowed memory size of 805306368 bytes exhausted (tried to allocate 72 bytes) in /folder/folder/Table.php on line 111

I guess increasing the memory again will solve this error but I think there must be some other issue as we should not need to increase the PHP memory so soon after doing it this time.

Hope this can help someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.