3

When I open my .co.uk website, it says a lot of stuff in Dutch from the pack I installed. I want my German website to be German, Dutch to be Dutch and English to be English.

Why it is not working?

How can I fix this?

I don't know from where to start. Is the switch able to be made in the database?

I tried to switch to developer mode, but than the system doesn't give a CSS to the backend, so I cannot get to the option.

My website:

https://www.thefixedgearshop.co.uk

The storeviews: Storeviews

Not switchable

Locale not switchable

6

You do not need to setup a "Website" instead of a "Store View". Store Views are used specifically for different languages if need.

Starting in magento 2.2.X you need to change the store to Developer Mode in order to update the Locale option.

php bin/magento deploy:mode:set developer

After applying the developer mode and the locales are deployed, revert back to Production mode

php bin/magento deploy:mode:set production

Look at this GitHub issue for more details: https://github.com/magento/magento2/issues/10377

| improve this answer | |
1

In your locale options, untick the "Use Website" and select your locale option.

| improve this answer | |
  • That is not possible. I cannot untick it cause its locked. – Axel Dekker Mar 16 '18 at 10:21
  • Ahh, if you want to have a different locale, you need to create a new website, not a store view. – Greg Mar 16 '18 at 10:25
  • So I need to switch my current storeview to a website, not a storeview? Does that infect the current information on the site or? Don't I already have that in website? – Axel Dekker Mar 16 '18 at 10:57
  • Have a look at this: magento.stackexchange.com/questions/7393/… – Greg Mar 16 '18 at 10:59
  • I checked it but if I look at my current set-up than that is correct? The storeviews I created are to show a store in a different language. The Locale says Dutch (Netherlands) for all of the languages. I cannot edit this? – Axel Dekker Mar 16 '18 at 11:05
0

No need to creat anew store view, just switch to developer mode, change it and switch back to production

php bin/magento deploy:mode:set developer --skip-compilation
| improve this answer | |
0

The only solution at the moment seems to be the one at https://github.com/magento/magento2/issues/10377#issuecomment-484470446

| improve this answer | |
0

You can actually just delete the "Disabled" attribute in the dom, make the change and save it. This should update the locale to what you specify.

Don't need to change modes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.