0

I wanted to install the German language packet from GitHub. https://github.com/mageplaza/magento-2-german-language-pack

Via composer I opened Putty and run first command line:

composer require mageplaza/magento-2-german-language-pack:dev-master

after this I wanted deploy via command:

php bin/magento setup:static-content:deploy de_DE -f

and now I see error: enter image description here

Page has stopped displaying: enter image description here

I have deleted module-core from vendor:

rm -rf vendor/mageplaza/module-core

and now error:

PHP Warning:  require(/home/fsg/domains/aron.pl/public_html/vendor/composer/../mageplaza/module-core/registration.php): failed to open stream: No such file or directory in /home/fsg/domains/aron.pl/public_html/vendor/composer/autoload_real.php on line 70
  • You can also add this as an answer and accept it later ... maybe this is helpfull for others too :) – sv3n Mar 12 '18 at 16:07
0

To solve this problem follow the steps below.

(depending on the version, it's called module-core or core-m2):

rm -rf vendor/mageplaza/core-m2 
rm -rf app/code/Mageplaza/Core
composer remove mageplaza/core-m2
composer dump-autoload
composer require mageplaza/module-core
php bin/magento setup:upgrade

*Before, connect to FTP and check module name on folder vendor/mageplaza/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.