I am getting an error while importing CSV in Magento 2.2:

"Imported resource (image) could not be downloaded from external resource due to timeout or access permissions in row(s): 4".

I tried all the solutions and also checked the folder permission (755). All the images are uploaded in /pub/media/import folder and in the CSV.

I just mention the name of the images.

  • can you share your csv cell where the image path is?
    – Adrian Z.
    Mar 12, 2018 at 11:33
  • base_image 152-205.jpg 152-220.jpg Mar 12, 2018 at 11:36
  • image path should be /152-205.jpg like that and put images in pub/media/import Aug 28, 2018 at 5:41

8 Answers 8


The error is saying that the image file referenced in row 5 (it says row 4, but that is the last successful imported row before the error) is missing or the spelling is incorrect. The import process cannot find the image at that location. If you remove the image name referenced in row 5, save, and then rerun the import, you should see several more rows imported until the next missing named file.


if anyone still facing the same problem on magento 2.3.3:

Solution: Product images has to be placed under Magento Root Folder>var>import>images so, upload all product images into this location and at import screen leave blank the

Images Files Directory

in your csv file under base_image and other image columns, only use the image name like AKTHY09.jpg and dont use relative paths with http or /../

hope this helps someone who is on CE 2.3.3

  • Hey buddy, Thank you very much you saved my hours. It is working in 2.3.3 version and i follow your steps as describe and import function is working fine for me.
    – Rik Patel
    Mar 18, 2020 at 9:08
  • enjoy Nayan, anyone find the solution and share it, all benefit ouf of this. Mar 19, 2020 at 13:57

If you have placed your images inside the /pub/media/import folder then you don't need to type the path in the CSV just add the image name and try to import. I had the same problem and today it worked for me hope it work for you also.


On Magento 2.2, I guess we need to use /pub/media/import folder with right permission/file ownership and on Import page to point to /pub/media/import in "Images file directory".

I have figured out now that on Magento 2.3.3 we dont need to enter a path while Magento 2.3.3 is pointing images folder as "var/import/images" by default. If you leave "Images file directory" import page blank/empty, then it works!

Below Link will help you to figure out:


Import images with CSV file on Magento 2.3.3


Instead of using /pub/media/import try this, create a folder called temp inside var folder and put all of your images there and use var/temp while import csv


Remove the path name from my CSV file and just have the image path as image.jpg with no slashes.


This is more likely to be a file/folder permission issue, creating a folder in var/temp solved my problem.


Just double check if images are there in your import folder any other from which you are uploading images.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.