0

Currently im pulling my hair out trying to get Magento to import a csv file. I have followed the following steps.

  1. Exported csv from Magento to get the layout 100% correct.
  2. Opened it in OpenOffice as a UTF-8 with it Separated by Tab and Comma
  3. Saved it and reopened it in Notepad++
  4. Resaved it as UTF-8 without BOM
  5. Attempted upload only with the following options selected in the Dataflow Profiles.

    Entry Type > Products, Decimal separator > ., Type > CSV / Tab separated, Value Delimiter > \t, Enclose Values In > ", Original Magento Attributes names in first row > Yes.

  6. I then save, and upload the file, save and run the profile.

  7. Failed. See below for screenshots and my csv file.

The CSV File - Size 1945KB << NSFW

The Error - Screenshot External.

Thank you in advance.

  • Thanks for the most NSFW text file I ever downloaded. From the screenshot, it looks as though you tried to import HTML... The text in that parse error is all HTML – David Wilkins May 28 '14 at 13:56
  • Yeah I forgot to say that its for a NSFW site, updated to warn people. – Zac Grierson May 28 '14 at 14:00
  • If I were you, I would try importing just a couple of lines EXACTLY as they come from the export. If that works, go step by step with those few lines and see if you can find where you went wrong – David Wilkins May 28 '14 at 14:01
  • That was my thinking. Ill give it a go, and try XML as I can get it in that format. – Zac Grierson May 28 '14 at 14:02
2

Your CSV is not formatted correctly.

Do not separate it by "Tab" and "Comma", just comma. Steps 3 & 4 seem to be unnecessary (I have never need to do those steps in 5 years). I'm wondering what step broke your CSV to make it look like what it looks like now.

CSV Format

I edited your file correctly formatted it. Give this one a try. https://www.dropbox.com/s/g89jcrycfzhqbnf/product.csv

| improve this answer | |
  • I'll retry with just comma. – Zac Grierson May 28 '14 at 14:07
  • 1
    There are tabs separating his fields, excel doesn't expect that in a *.csv file. Open it in notepad to see what I mean – David Wilkins May 28 '14 at 14:07
  • Yeah I saw that in notepad, though I thought the Excel screenshot would show the issue better. I ended up reformatting the file and I just posted a link of my changes. – kab8609 May 28 '14 at 14:12
  • I tried but got the same results. Here is a screenshot of my settings for import. Sceenshot – Zac Grierson May 28 '14 at 14:31
  • Change "number of records" to 1. No one has the "number of records" at a time set to 2,200. – kab8609 May 28 '14 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.