3

I've disabled and enabled and cleared and flushed cache through

php bin/magento cahce:disable
php bin/magento cahce:enable
php bin/magento cahce:clean
php bin/magento cahce:flush

Recently i just noticed i turned the cache on and then in admin it's showing that they are all disabled still.

Also, after selecting actions there is only refresh too in the drop down.

enter image description here

It's not a big deal because i can cross reference the DB to make sure they are turned on as well as using cmd line but it's kind of bugging me that they are still red and i can't use the admin caching panel.

EE 2.2.3

Any ideas?

enter image description here

Maybe i didn't setup my env.php file correctly? Is there anything that stands out to you as wrong?

<?php
return array (
  'backend' => 
  array (
    'frontName' => 'admin',
  ),
  'db' => 
  array (
    'connection' => 
    array (
      'indexer' => 
      array (
        'host' => 'localhost',
        'dbname' => '2_EE',
        'username' => 'user',
        'password' => 'pass',
        'active' => '1',
        'persistent' => NULL,
      ),
      'default' => 
      array (
        'host' => 'localhost',
        'dbname' => '2_EE',
        'username' => 'user',
        'password' => 'host',
        'active' => '1',
      ),
    ),
    'table_prefix' => '',
  ),
  'crypt' => 
  array (
    'key' => 'b****',
  ),
  'resource' => 
  array (
    'default_setup' => 
    array (
      'connection' => 'default',
    ),
  ),
  'x-frame-options' => 'SAMEORIGIN',
  'MAGE_MODE' => 'developer',
  'session' => 
  array (
    'save' => 'redis',
    'redis' => 
    array (
      'host' => '127.0.0.1',
      'port' => '6379',
      'password' => '',
      'timeout' => '2.5',
      'persistent_identifier' => '',
      'database' => '2',
      'compression_threshold' => '2048',
      'compression_library' => 'gzip',
      'log_level' => '7',
      'max_concurrency' => '6',
      'break_after_frontend' => '5',
      'break_after_adminhtml' => '30',
      'first_lifetime' => '600',
      'bot_first_lifetime' => '60',
      'bot_lifetime' => '7200',
      'disable_locking' => '0',
      'min_lifetime' => '60',
      'max_lifetime' => '2592000',
    ),
  ),
  'cache' => 
  array (
    'frontend' => 
    array (
      'default' => 
      array (
        'backend' => 'Cm_Cache_Backend_Redis',
        'backend_options' => 
        array (
          'server' => '127.0.0.1',
          'database' => '0',
          'port' => '6379',
        ),
      ),
      'page_cache' => 
      array (
        'backend' => 'Cm_Cache_Backend_Redis',
        'backend_options' => 
        array (
          'server' => '127.0.0.1',
          'port' => '6379',
          'database' => '1',
          'compress_data' => '0',
        ),
      ),
    ),
  ),
  'cache_types' => 
  array (
    'config' => 1,
    'layout' => 1,
    'block_html' => 1,
    'collections' => 1,
    'reflection' => 1,
    'db_ddl' => 1,
    'eav' => 1,
    'customer_notification' => 1,
    'config_integration' => 1,
    'config_integration_api' => 1,
    'target_rule' => 1,
    'full_page' => 1,
    'translate' => 1,
    'config_webservice' => 1,
    'compiled_config' => 1,
  ),
  'install' => 
  array (
    'date' => 'Fri, 02 Mar 2018 18:06:06 +0000',
  ),
  'system' => 
  array (
    'default' => 
    array (
      'dev' => 
      array (
        'debug' => 
        array (
          'debug_logging' => '0',
        ),
      ),
    ),
  ),
);

I have redis installed and i've used redis-cli flushall as well.

I've installed two modules today and when i check to see if they are installed on command line bin/magento modules:status I see that they are there and installed but they as well are not appearing on the backend.

closed as off-topic by Marius Jul 19 '18 at 15:20

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced OR seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Marius
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Are there any other cache backend mechanisms at play besides default files? Judging from the bookmarks/tabs possibly memcache or redis? Also if Varnish is in place in front of your web server it could be cached there as well. If redis github.com/erikdubbelboer/phpRedisAdmin and an easy one-liner for memcache: watch 'php -r '"'"'$m=new Memcache;$m->connect("127.0.0.1", 11211);print_r($m->getstats());'"'" – B00MER Mar 9 '18 at 4:05
  • 1
    Yes, I just installed redis but i feel like it was happening before that too. Although, I'm not really sure; I'll just go with it started happening after installing redis since you mentioned that could be why. I like the redis admin module. I may install that module. Thank you – getData Mar 9 '18 at 16:14
  • 1
    @B00MER I notice other things are missing as well. ie. Stores > Configuration > Advanced... I only have Admin and System.. no Developer tab... see image above. – getData Mar 14 '18 at 21:50
  • 1
    Judging from the screenshot, disabling some of the 3rd party modules may help identify the culprit, as out-of-box Magento 2.2.x should function properly. Most likely as you notice the missing developer setting is related to your caching issue. BTW, I censored your crypt key just to be safe. – B00MER Mar 15 '18 at 4:13
  • 1
    Thanks @B00MER, I've only installed 3 modules total and the first one was B2B. It was happening before i installed the two new 3rd party modules yesterday. – getData Mar 15 '18 at 14:16
0

I never found an answer to this question but what I ended up doing was just reinstalling and starting over. I guess we can just mark this as closed.

Not the answer you're looking for? Browse other questions tagged or ask your own question.