0

I made disable "Magento_Theme" module in ( Stores/Configuration/Advanced/Disable Modules Output), but after disabling I cannot see admin page (It's black page) and even storefront page, too. (Even I cannot see login page).. Is there anything I can do? (I think Magento is fail to set theme correctly when it load a page...).

I already tried to clear cache, all generation files... Btw, this is Magento 2 store application. Please help me..

enter image description here

2 Answers 2

0

Try enabling it from database table itself. In database Go to core_config_data table and search for value advanced/modules_disable_output/Magento_Theme in path column and set its value to 0.

Suggestion: You should not disable any core module directly, there are dependencies of modules.

5
  • There is no table named "core_config_data" in phpMyAdmin. Instead I found a table "authorization_rule". Is it also configurable table?
    – Yun
    Commented Mar 7, 2018 at 18:33
  • There must be a table with this name, it may have a prefix if you have added while installation. Hope you are checking in right database
    – Piyush
    Commented Mar 7, 2018 at 18:35
  • I found it, and changed the value to 0 and cleaned all caches and generations. I think it works now, but it seems that loading js/css files failed. Should I apply Magento_Theme again? or Do I need to fix extra thing?
    – Yun
    Commented Mar 7, 2018 at 18:44
  • try to run compile command again and check
    – Piyush
    Commented Mar 7, 2018 at 18:47
  • Thank you! At least it works for now except compiling issue. I created a new ticket for issue magento.stackexchange.com/questions/216444/… . By the way, you saved my life!!
    – Yun
    Commented Mar 7, 2018 at 18:59
1

Open app/code/config.php file and there search for 'Magento_Theme'. It would be set Magento_Theme => 0. change this to.

'Magento_Theme' => 1

After that clear cache, clear genration and then run setup:upgrade , setup:di:compile and setup:static-content:deploy command. hope it will work.

3
  • It was 1 even after I disable the module, I checked "bin/magento module:status" and "Magento_Theme" enabled. Should I re-compile again?
    – Yun
    Commented Mar 7, 2018 at 18:34
  • yes, you have to compile again, but make sure to delete fronted, adminhtml folders only in pub/static. and code in generation folder. Commented Mar 7, 2018 at 18:37
  • I tried to compile but there is another issue.. I created another ticket about the issue. Thank you anyway! magento.stackexchange.com/questions/216444/…
    – Yun
    Commented Mar 7, 2018 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.