2

Trying to upgrade Magento Commerce (EE) to 2.2.3 from 2.2.2 using composer, however, the package doesn't seem to be available in repo.magento.com - anyone else had this problem?

Tried a lot of debugging, composer cache clearing, etc, but got me nowhere.

Any ideas would be greatly appreciated!

Thanks


Update

Turns out it was another composer-installed module that was preventing me from doing the upgrade, unfortunately still don't know to this day why composer didn't tell me about it, the way it usually does in these situations.

Oh well, panic over!

  • If you are using EE then they will provide you procedure to upgrade. – Pramod Kharade Mar 7 '18 at 15:26
  • That is the problem, following the documentation and is failing. However, tying different other things and I think I'm on to something, but as I said, still doing some tests before updating this post. – George Schiopu Mar 7 '18 at 15:40
  • Small update: there seems to be a problem in that repo somehow, tried to copy the composer.json file alone in a new dir and triggered the usual composer require [...] and composer update and worked like a charm. There must be a constrain somewhere/somehow, just didn't find it yet. – George Schiopu Mar 9 '18 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.