0

Trying to remove VladimirPopov_WebForms from FTP.

  1. Went to /app/etc/modules/VladimirPopov_WebForms.xml and put status to false.
  2. Admin panel -> System - Configuration-< VladimirPopov_WebForms disabled
  3. Removed all files from server
  4. cleared cash
  5. compilation is off

now, main page of admin panel is working but if I go to for example to Cache page Im getting this:

Fatal error: Uncaught Error: Class 'Mage_Webforms_Helper_Data' not found in /public_html/app/Mage.php:547 Stack trace: #0 /public_html/app/code/core/Mage/Adminhtml/Block/Page/Menu.php(325): Mage::helper('webforms') #1 /public_html/app/code/core/Mage/Adminhtml/Block/Page/Menu.php(144): Mage_Adminhtml_Block_Page_Menu->_isEnabledModuleOutput(Object(Varien_Simplexml_Element)) #2 /public_html/app/code/core/Mage/Adminhtml/Block/Page/Menu.php(98): Mage_Adminhtml_Block_Page_Menu->_buildMenuArray() #3 /public_html/app/code/community/Ess/M2ePro/Block/Adminhtml/Magento/Menu.php(23): Mage_Adminhtml_Block_Page_Menu->getMenuArray() #4 /public_html/app/design/adminhtml/default/default/template/page/menu.phtml(30): Ess_M2ePro_Block_Adminhtml_Magento_Menu->getMenuArray() #5 /public_html/app/code/core/Mage/Core/Block/Template.php(241): include('/home/dscfilte/...') #6 /public_html/app/code/core/Mage/Core/Block/Template.php(272): in /public_html/app/Mage.php on line 547

Update: after returning everything back, I noticed that there is one table mag1_webforms and without this table nothing works, really confused now, dont know what I did wrong.

  • compilation is enable in your webshop? – Keyur Shah Mar 6 '18 at 2:49
  • everything was off, I end up deleting everything except one table from database and /app/etc/modules/VladimirPopov_WebForms.xml, for now it's working. Maybe somebody here gonna have an idea – Olga Bautina Mar 6 '18 at 17:40
1

Just saw this and was looking for some help myself. I followed these steps:

-log in to ssh and go to /app/etc/modules and edit VladimirPopov_WebForms.xml and set true to false -Look for tables in the sql database that are directly for this module webforms webforms_fields webforms_fieldsets webforms_logic webforms_message webforms_quickresp webforms_results webforms_results_values webforms_store -Check the tables to see if they have any valuable data and download it delete these tables -In Database, Remove resource config record for the respective module from core_resource - use search function to find %webforms% -Remove the app/code/community/VladimirPopov folder

BEWARE, followed these steps and it broke the site. (Note, i did forget to clear the cache and that may have been the problem but when i did the extra step below it started working without clearing the cache)

So I used phpmyadmin to do a search on the database and delete references to webforms and i was able to get it back working. I am not sure exactly which ones corrected the issue but I am able to use the site normally and don't have any of the webforms tables left over.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.