3

Unfortunately, I stopped by some issue I cannot find the answer for, no matter how much I search online.

When I attempt to reindex through terminal using the following code:

php bin/magento indexer:reindex

Only the first table (Design Config Grid) seems to be properly rebuilt:

Only design grid is rebuilt

In the Admin panel, the only table that is not reindexed is the "Customer Grid" table:

The customer Grid is not reindexed I am assuming the reason must be related to the "Customer Grid". Would you please help me figure this out? Any help is greatly appreciated.


Magento 2.2.2

1
  • I have also been struggling with this exact issue all day. I will post a solution if I manage to figure it out. Jun 19 '18 at 12:27
1

There are some excellent suggestions at Magento 2: Not showing customers in backend grid

Namely:

php bin/magento indexer:reset customer_grid

php bin/magento indexer:reindex customer_grid

0
0

I finally managed to figure this out my end. I have a few things for you to try out. Firstly I would recommend enabling error_reporting in your php.ini file. This will output where the fatal error occurred.

When I enabled error reporting this is the error it returned:

Fatal error: Uncaught Error: Class 'Locale' not found in [root]/vendor/magento/framework/Locale/Bundle/DataBundle.php:64

If you get this same error it is likely you don't have the intl php extension installed on your server. I did have this installed on php7.1, but because I was on shared hosting and servers default php version was 7.0, this meant the shell was using php7.0.

So what I did was point my shell to the directory of the php version I wanted to use and then ran the indexer.

/opt/cpanel/ea-php71/root/usr/bin/php bin/magento indexer:reindex


NOTE

I found the path to my php version by running this command in the shell.

php -i | grep php.ini

This then gave me a general idea of the path to where my PHP version was located:

Configuration File (php.ini) Path => /opt/cpanel/ea-php70/root/etc
Loaded Configuration File => /opt/cpanel/ea-php70/root/etc/php.ini

From this /opt/cpanel/ea-php70/root/etc part of the response I worked out the path to my php7.1 install was:

/opt/cpanel/ea-php71/root/usr/bin/php


Hopefully this resolves your issue, or at least points you in the right direction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.