0

I have a Magento 1.8.1 with the Module SMTPPro installed (latest version). When a client makes an order, the admin receives an email with the order.

The problem is that the "from" appears to be the store's email address instead of client's email address.

What should I change in order to make sure that the "From" is client's email address, and not the store email address.

Any idea might help. Anticipate thanks.

0

In order to set the "Reply To" header as client's email address you have to:

1) Open the file: Magento-SMTP-Pro-Email-Extension/app/code/local/Aschroder/SMTPPro/Model/Email/Template.php

2) Go to line 119, where is: $mail->setFrom($this->getSenderEmail(), $this->getSenderName());

3) After this line, add the following code:

if(Mage::getDesign()->getArea() == 'adminhtml'){ //only can set if email sending from backend
    if (method_exists($mail, "setReplyTo")) {
        $mail->setReplyTo($this->getSenderEmail(), $this->getSenderName());
    } else {
        $mail->addHeader('Reply-To', $this->getSenderEmail());
    }
    Mage::log('ReplyToStoreEmail is enabled, just set Reply-To header: ' . $this->getSenderEmail());
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.