0

I recently migrated my magento site from one server to another but I noticed I cannot upload images, actually when i cleared image cache, all product images disappeared. Here is a screenshot of the error received.

enter image description here

I have given suggested permissions to the respective folders but I am still experiencing the same issue. I noticed the product image was been pulled from /media/catalog/product/cache. Once i deleted that folder, all product images from frontend disappeared, however, backend images are showing

  • Sounds like your media directory isn't writable by the web server, try the following command if you have SSH access: find . -type d -name 'media' -exec chmod 2775 {} \; – Matt Antley Mar 2 '18 at 12:55
  • @MattAntley it didnt work. I have tried 777 too – Peter Okachie Mar 2 '18 at 16:19
0

Check the Permissions on your new server. Most likely the media/tmp directory is your issue. Either the Owner of the directory is not your server's user. Or it just doesn't have enough permissions granted.

  • I have given suggested permissions to the respective folders but I am still experiencing the same issue. I noticed the product image was been pulled from /media/catalog/product/cache. Once i deleted that folder, all product images from frontend disappeared, however, backend images are showing – Peter Okachie Mar 2 '18 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.