0

after uploading my marketplace-module in

app/code

i've run the command as

php bin/magento module:status

but it gave me the following error as shown in image : enter image description here

i checked the file permission of magento in

bin/magento it is set to 0755 after that i tried to change the permission to 0777 but no chnage im still getting this error

could not open the file bin/magento 

can anoyone tell me what is going wrong from my side? thanks in advance.

7
  • 1
    run this command from magento root folder Commented Mar 2, 2018 at 6:51
  • how? im using this command from ssh... how to navigate to magento root folder? i dont have much knowledge about that
    – Laiba
    Commented Mar 2, 2018 at 6:57
  • how did you uploaded that marketplace module? Commented Mar 2, 2018 at 7:01
  • i've bought that module and then uploaded it in app/code after that i run the command
    – Laiba
    Commented Mar 2, 2018 at 7:02
  • i've also tried using composer require mydoule:moduleVersion but that further gave me the following error Your requirements could not be resolved to an installable set of packages. Problem 1 - The requested package medma/module-marketplace could not be found in any version, there may be a typo in the package name. Potential causes: - A typo in the package name - The package is not available in a stable-enough version according to your minimum-stability setting and more
    – Laiba
    Commented Mar 2, 2018 at 7:03

1 Answer 1

0

To navigate in putty try to use Midnight Commander.

  1. install package sudo apt install mc
  2. type mc
  3. navigate to magento root directory (basically is /var/www/...)

or use WinSCP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.