0

i want to install marketplace extension on magento 2.2 but don't know how. i've opend my ssh but what to do now? or do i have to upload this extension's files directly on cPanel? If yes, then please tell me the path where the file of extension should be uploaded. can anyone help me with this?

  • did you got solution ? – Pawan Mar 1 '18 at 18:13
  • no @Pawan im still working to find the soltuion – Laiba Mar 2 '18 at 6:32
  • Hello @Laiba, did you try my answer ? – Pawan Mar 6 '18 at 3:11
0

To install your extension by ssh and magento cli, upload your module files on app/code folder. Pay attention on the extension files, there is a structure that it must respect, see how it must appear:

app/code/YourVendor/YourModule/ all other module files ...

so you can run this comands (be with prompt on your magento folder installation):

php bin/magento module:status to list all your modules, installed or not.

php bin/magento module:enable YourVendor_YourModule to enable your module, where "YourVendor" and "YourModule" must be overrided by vendor name and module name.

php bin/magento setup:upgrade setup your module configurations on magento.

And depending of what your module do, and where it acts, the following commands must be necessary, maybe.

php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy -f

  • @ipFranz i've uploaded the file in the backend app/code/my_module ... i am using medma marketplace ... now do i have to run command as : >php bin/magento module:enable medma_marketplace ? – Laiba Mar 2 '18 at 5:35
  • Normaly, the name of a module is in camel case, like: Medma_Marketplace, but to be sure about it, open the registration.php file of your module, the name is the only string at that file. – lpFranz Mar 2 '18 at 11:20
  • [InvalidArgumentException] Could not find package Medma_MarketPlace at any version for your minimum-st ability (stable). Check the package spelling or your minimum-stability this is the error im facing – Laiba Mar 2 '18 at 11:24
  • Aparently, your folders structure are with some error, if the name of your module is "Medma_MarketPlace", you must have a structure like this: app/code/Medma/MarketPlace/, and then in this folder are all the module files, like registration.php, etc folder, Block folder, etc. – lpFranz Mar 2 '18 at 11:30
  • About your other issue, could not open the file bin/magento error, I suggest to you create another question, cause post an answer as another question violates some forum rules, and it can be a problem. – lpFranz Mar 2 '18 at 11:33
0

after uploading my marketplace-module in

app/code

i've run the command as

php bin/magento module:status

but it gave me the following error as shown in image : enter image description here

i checked the file permission of magento in

bin/magento it is set to 0755 after that i tried to change the permission to 0777 but no chnage im still getting this error

could not open the file bin/magento 

can anoyone tell me what is going wrong from my side? thanks in advance.

0

You are getting could not open the file bin/magento because you are not running the command from your Magento installation location, instead you are trying to run it from your home directory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.