0

I am pretty new to magento. After I change to client-side less compilation. I get the following.

1 exception(s):
Exception #0 (Exception): Notice: Undefined variable: template in 
/var/www/html/vendor/magento/framework/View/Page/Config/Renderer.php on line 
357

Exception #0 (Exception): Notice: Undefined variable: template in 
/var/www/html/vendor/magento/framework/View/Page/Config/Renderer.php on line 
357
#0 
/var/www/html/vendor/magento/framework/View/Page/Config/Renderer.php(357): 
Magento\Framework\App\ErrorHandler->handler(8, 'Undefined varia...', 
'/var/www/html/v...', 357, Array)
#1 
/var/www/html/vendor/magento/framework/View/Page/Config/Renderer.php(239): 
Magento\Framework\View\Page\Config\Renderer-
>renderAssetHtml(Object(Magento\Framework\View\Asset\PropertyGroup))
#2 
/var/www/html/vendor/magento/framework/View/Page/Config/Renderer.php(226): 
Magento\Framework\View\Page\Config\Renderer-
>renderAssetGroup(Object(Magento\Framework\View\Asset\PropertyGroup))
#3 /var/www/html/vendor/magento/module-
developer/Model/View/Page/Config/ClientSideLessCompilation/Renderer.php(87): 
Magento\Framework\View\Page\Config\Renderer->renderAssets(Array)
#4 /var/www/html/vendor/magento/framework/View/Page/Config/Renderer.php(99): 
Magento\Developer\Model\View\Page\Config\ClientSideLessCompilation\Renderer-
>renderAssets(Array)
#5 /var/www/html/vendor/magento/framework/View/Result/Page.php(249): 
Magento\Framework\View\Page\Config\Renderer->renderHeadContent()
#6 /var/www/html/vendor/magento/framework/View/Result/Layout.php(170): 
Magento\Framework\View\Result\Page-
>render(Object(Magento\Framework\App\Response\Http\Interceptor))
#7 /var/www/html/vendor/magento/framework/Interception/Interceptor.php(58): 
Magento\Framework\View\Result\Layout-
>renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#8 /var/www/html/vendor/magento/framework/Interception/Interceptor.php(138): 
Magento\Framework\View\Result\Page\Interceptor-
>___callParent('renderResult', Array)
#9 /var/www/html/vendor/magento/framework/Interception/Interceptor.php(153): 
Magento\Framework\View\Result\Page\Interceptor-
>Magento\Framework\Interception\{closure}
(Object(Magento\Framework\App\Response\Http\Interceptor))
#10
/var/www/html/generated/code/Magento/Framework/View/Result/Page/Interceptor.
php(26): Magento\Framework\View\Result\Page\Interceptor-
>___callPlugins('renderResult', Array, Array)
#11 /var/www/html/vendor/magento/framework/App/Http.php(139): 
Magento\Framework\View\Result\Page\Interceptor-
>renderResult(Object(Magento\Framework\App\Response\Http\Interceptor))
#12 /var/www/html/vendor/magento/framework/App/Bootstrap.php(256): 
Magento\Framework\App\Http->launch()
#13 /var/www/html/pub/index.php(37): Magento\Framework\App\Bootstrap-
>run(Object(Magento\Framework\App\Http\Interceptor))
#14 {main}

Any help is appreciated.

1 Answer 1

0

Try to clear /var/www/html/generated folder and clear cache. If that doesn't help - just redeploy static content after you clear /var/www/html/generated and /var/www/html/var/view_preprocesed folders

1
  • I have already tried both. Didn't seem to help.
    – Neha
    Mar 2, 2018 at 3:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.