0

When i'm using Magmi Importer UI its working fine but when I'm trying to import the same from cli. I'm using magmi's 0.7 version in magento 1.7.0. I'm getting this error

     Call to a member function getRecordsCount() on a non-object in  /var/www/vhosts/Outletzon.secureserver.net/httpdocs/testdocs/magmi/engines/magmi_productimport engine.php on line 1404

I'm using this command to in cli

 php magmi.cli.php -profile=Default -mode=create -CSV:filename="/var/import/kids-baby.csv"
  • Open up engine.php on line 1404 and implement some logging to narrow down the problem. Magmi is a developer tool and requires a developer's understanding to use, implement and debug. – Axel Jun 3 '14 at 16:42
  • 4
    This question appears to be off-topic because it is about a third party extension. – Matthias Zeis Nov 19 '14 at 21:50
2

the problem comes from your command line option:

-CSV:filename='/var/import/kids-baby.csv"

This is an "absolute" path so it will try to lookup for the file in the "/var" directory which i doubt it is.

What you wanted is to access the "var/import" directory under magento root, which is not your filesystem root.

so you need to put something like

-CSV:filename='/var/www/vhosts/Outletzon.secureserver.net/httpdocs/var/import/kids-baby.csv"

assuming your magento root is under httpdocs.

|improve this answer|||||
  • I tried it but still I'm getting same error on the same line number in the same file – Saurabh Singh May 28 '14 at 7:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.