0

I've been using Magento 1 a while and wanted to see what Magento 2 was like.

I installed it via cpanel with the demo content.

The home page has a slider and other blocks of images / products.

I go to the home page in the content> pages section and see there is nothing on the page.

I check the static blocks and see there is a home page static block.. but I have to ask.

1) Why use a static block for this when you could have just put in on the page 2) How is the static block being called / pulled to the home page ?

When i use static blocks in Magento 1 I use code like

{{block id="block_name"}} 

to call the content.

  • Hi Dave, sorry to hear M2 is a challenge. It's indeed a whole other beast than M1 but from experience, I can tell you that it's worth diving into. To get the best response on this forum I would like advise you to refactor your question a bit. Keep the question objective. M2 is hard but it's just a fact of life. 1 question per post: to keep the goal of the question clear. Describe exactly what you run into. try to be exact in what you want to accomplish – Sander Mangel Feb 27 '18 at 11:10
  • Thanks... Do you mean you'd like me to edit this question now or just going forward ? – DaveYme Feb 27 '18 at 11:13
  • If you can please edit the question now so we can work towards getting it reopened – Sander Mangel Feb 27 '18 at 13:57
  • Changed it to be more directed to the static block part. – DaveYme Feb 27 '18 at 14:26
1

Is 2 made more complex on purpose?

As someone currently migrating to Magento 2, this is a question I find myself asking every day...

how is the static block appearing on the page?

I can't remember off the top of my head, but if you search online you'll find the answer - this was one of the first things I changed. Layout/design editing is heavily XML-based in Magento 2, so it'll likely be changed in a config file.

I made a new page with just some demo text to see how it looked and there was no menu / search bar / login area on the page.. I couldn't see how to add it either

This is just the default value (Empty) for the "Layout" option in the page "Design" tab - change to 1 column (or whichever value you'd like), refresh/flush your cache, and check again.

It's a steep learning curve, but things do begin to slowly make sense. Good luck!

| improve this answer | |
  • thanks. it was the cache flush that was the issue. Thanks. – DaveYme Feb 27 '18 at 16:25

Not the answer you're looking for? Browse other questions tagged or ask your own question.