1

I was making some changes in a phtml file to my Magento store

There has been an error processing your request Exception printing is disabled by default for security reasons. Error log record number: 927546133845

I now cannot get any access onto the site or into my admin system. Looking at the report for the number above I have but being new to magento i don't understand any of it:

a:5:{i:0;s:48:"SQLSTATE[HY000] [2002] No such file or directory";i:1;s:1575:"#0 /home/xxxxxx/public_html/lib/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home/xxxxxx/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(320): Zend_Db_Adapter_Pdo_Mysql->_connect()
#2 /home/xxxxxx/public_html/lib/Zend/Db/Adapter/Abstract.php(459): Varien_Db_Adapter_Pdo_Mysql->_connect()
#3 /home/xxxxxx/public_html/lib/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#4 /home/xxxxxx/public_html/lib/Varien/Db/Adapter/Pdo/Mysql.php(428): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#5 /home/xxxxxx/public_html/app/code/core/Mage/Core/Model/Resource.php(169): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#6 /home/xxxxxx/public_html/app/code/core/Mage/Core/Model/Resource.php(110): Mage_Core_Model_Resource->_newConnection('pdo_mysql', Object(Mage_Core_Model_Config_Element))
#7 /home/xxxxxx/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(141): Mage_Core_Model_Resource->getConnection('core_setup')
#8 /home/xxxxxx/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(234): Mage_Core_Model_Resource_Setup->__construct('core_setup')
#9 /home/xxxxxx/public_html/app/code/core/Mage/Core/Model/App.php(417): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#10 /home/xxxxxx/public_html/app/code/core/Mage/Core/Model/App.php(343): Mage_Core_Model_App->_initModules()
#11 /home/xxxxxx/public_html/app/Mage.php(684): Mage_Core_Model_App->run(Array)
#12 /home/xxxxxx/public_html/index.php(87): Mage::run('', 'store')
#13 {main}";s:3:"url";s:13:"/browse/cases";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

Can anyone help? I urgently need to get this site back up

1 Answer 1

2

I think the problem is quite straightforward: you're using MySQL socket and either your socket path is wrong or the socket file itself is missing. Did you change hosting or computer? If not, then probably you need to start your MySQL (or MariaDB if that's your tool).

5
  • No i the hosting or computer has not changed. It has been fine since installation 5-6 weeks ago but all of a sudden after just changing some code in one of my phtml files it has done this
    – odd_duck
    Commented May 26, 2014 at 18:18
  • Are you sure that MySQL otherwise is just fine? Maybe it crashed or have been stopped? Check app/etc/local.xml to find out what is the socket path and make sure that it actually exists.
    – Pronto
    Commented May 26, 2014 at 18:26
  • All ok now, was an issue with the hosting company, now they have resolved it is back up, phew!
    – odd_duck
    Commented May 26, 2014 at 19:49
  • 1
    Your MySQL was probably just stopped when hosting company updated something and they forgot to reload it again.
    – Pronto
    Commented May 26, 2014 at 19:59
  • @Pronto - Heh had that happen once. Quality hosting providers tend to have checklists for that type of thing and upgrades and updates just happen automagically now. They also tend to understand that downed sites are money out of pocket for their customers and work hard at preventing either intentional or accidental loss of service. Commented Jun 22, 2014 at 4:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.