0

I was trying to print an order collection array (\Magento\Sales\Model\ResourceModel\Order\CollectionFactory), but it never gets printed, I know the reason.

Now when I reload my browser, I get a 503 Service Temporarily Unavailable everywhere, frontend and backend.

There is no maintenance.flag or even .maintenance.flag anywhere in var/ folder.

Mode - developer, Hosted on NGINX, plesk (other sites on same server working). I tried deleting cache, indexing, static contents deploy everything.

The error in /var/log/nginx/error.log is:

2018/02/22 11:36:56 [notice] 9870#0: signal process started 2018/02/22 11:36:56 [error] 9870#0: open() "/var/run/nginx.pid" failed (2: No such file or directory)

Kindly help!

  • Did you try looking in the Apache/Nginx error logs? – Ethan Yehuda Feb 22 '18 at 13:10
  • Any recent changes? Are you using Apache or NginX? – Greg Feb 22 '18 at 13:11
  • I am using nginx – Kumar A. Feb 22 '18 at 13:22
  • @EthanYehuda i have updated my question – Kumar A. Feb 22 '18 at 13:29
  • 1
    @KumarA. I have posted the answer, that should solve your problem. – Greg Feb 22 '18 at 15:49
0

Reload your NginX configuration:

If your system has systemctl

sudo systemctl reload nginx

If your system supports service (using debian/ubuntu) try this

sudo service nginx reload

If not (using centos/fedora/etc) you can try the init script

sudo /etc/init.d/nginx reload

Please make sure that you reload and not restart.

  • Reloading keeps the server running while re-reading any configuration file updates.

  • Reloading is safer than restarting because if a syntax error is noticed in a config file, it will not proceed with the reload and your server remains running.

  • If there is a syntax error in a config file and you restart, it's possible the server will not restart correctly.

  • easy to run just nginx -t .many times seen it will restart/reload without any messages... this is not magento issue anyway. then afterall you must check if pid is running ps aux | grep nginx – MagenX Feb 22 '18 at 22:16
  • Sorry for my late response, but restarting nginx worked. However, i cannot manage to get any solution to core reason of this, but for now i am ready to move ahead. Thanks – Kumar A. Feb 28 '18 at 14:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.