1

I am trying to install M2ePro module on my Magento ver. 2.1.8 application using composer and getting this error:

[http]$ php-7.0 /usr/local/bin/composer require m2e/ebay-amazon-magento2

Could not find a matching version of package m2e/ebay-amazon-magento2. Check the package spelling, your version constraint and that the package is available in a stability which matches your minimum-stability (alpha).

The spelling of the package is correct, I have tried defining the version of the module (The only one available is 1.3.2):

[http]$ php-7.0 /usr/local/bin/composer require m2e/ebay-amazon-magento2:1.3.2

However get the same error so I believe stability of this module is "Beta" and I have "minimum-stability (alpha)" set so beta modules should be installed with no problems.?

I looked for solution in composer docs but could find anything about installing beta: https://getcomposer.org/doc/03-cli.md#require

Or was I looking in the wrong place?

I managed to successfully install the module on my development site and didn't receive this error so I thought it might be due to the fact that my Magento application was in the "Production" mode but setting the mode to "Developer" did not solve my problem.

UPDATE:

I just found this thread: Error in using composer to install a module in Magento 2.0. The answer to this question is that you need to define the package as repository. The package is from marketplace and this is content of my composer.json:

"minimum-stability": "alpha",
"prefer-stable": true,
"repositories": [
    {
        "type": "composer",
        "url": "https://repo.magento.com/"
    }       
],

I have previously installed modules from marketplace using composer with no problems.

  • have you tried a manual installation of the module instead of using composer? – sissy Feb 22 '18 at 10:27
  • I have not, however, that will not solve my problem. I want to use composer to handle all my packages and installing the module manually will not update the .lock file or composer.json – Greg Feb 22 '18 at 10:31
1

I see, my suggestion to install it manually, was just a try you could do to see if the module was able to find its dependencies. Btw you should change your stability requirements in your composer.json

from

"minimum-stability": "stable"

to

"minimum-stability": "alpha"

then run composer update and all other needed commands.

  • Thank you for the answer. The module installed with no problems on my development site and is not that polite on the live website. Could it be due the the fact that my live website is in production mode? Should I change the mode before installing the module? Also, I believe the minimum-stability of my composer.json is already set to "alpha". – Greg Feb 22 '18 at 10:40
  • yes you should try to set in developer mode, maybe in production mode it is not allowed to se that level of stability. – sissy Feb 22 '18 at 10:42
  • I have just tried to switch to production mode and it still gives me the same error :/ Any ideas? – Greg Feb 22 '18 at 11:15
1

It came out that my auth.json had incorrect credentials and could find the account.

Correcting the account settings fixed my problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.