6

I have a strange issue on one of the site. When I log in or register as a new customer and adding few items in shopping cart. Then go to the checkout page it is automatically logged out the customer in some random cases.

Sometimes it just logged out the user when I come to the checkout page. Sometimes it logged out the user when I go to the payment selection page. This is random behavior. Also in some cases, I can able to place an order with logged in but in success page, it is automatically logged out the customer.

enter image description here

enter image description here

4
  • Is this behavior same in all browsers ? – Kalyan Chakravarthi V Feb 20 '18 at 17:02
  • Yes it is same in all browsers – Akhilesh Patel Feb 20 '18 at 17:18
  • where are you saving the session and is there any backend cache implemented like memcache, redis etc? If so, try disabling them and check. – Kalyan Chakravarthi V Feb 21 '18 at 3:45
  • @KalyanChakravarthiV There is no additional cache implemented in the system. But there are too many extensions installed and many customisation done on the site. So might be an issue that previous developer used session somewhere in code and that might be causing some issue. I already disabled all custom and third party extensions and theme as well. – Akhilesh Patel Feb 21 '18 at 5:23
2

I found this is the default Bug in Magento CE 2.2.2 and reported it on github https://github.com/magento/magento2/issues/13889

There is one catalog setting is set to YES in my site and that was causing this issue. When I set it back to NO it is working fine. This issue is only coming in Magento version 2.2.2 as we have upgraded it from Magento version 2.1.7 and it was working fine with that version.

enter image description here

1
  • its worked for me – matinict Mar 16 at 9:13
0

This is occurring on our site (v2.2.2). If I select the "Checkout" button on the basket page before all sections had completed (totals section in my case), the user is logged out and sent to the login page.

If I wait until the basket page has fully displayed, the issue does not occur.

I have checked the "synchronise widget products" setting and this is already set to No.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.