0

I followed the below steps to install B2B extension in Magento 2.2.2 EE by referring to this link

  • Install Magento 2.2.2EE with sample data

  • Run the below commands

    composer require magento/extension-b2b
    bin/magento setup:upgrade
    bin/magento setup:di:compile
    bin/magento setup:static-content:deploy
    bin/magento queue:consumers:start sharedCatalogUpdatePrice &
    bin/magento queue:consumers:start sharedCatalogUpdateCategoryPermissions &
    bin/magento queue:consumers:start quoteItemCleaner &
    bin/magento queue:consumers:start inventoryQtyCounter &
    
  • Enable B2B features in admin http://nimb.ws/s0khR2

  • Run the reindex command bin/magento indexer:reindex

  • After that Storefront display no products http://nimb.ws/3W8xKY, all the product/category url goes to no-route page (http://192.168.14.58/2.2.2/no-route)

Please advice me to fix this issue. Thanks.

1
  • its because of shared catalog functionality of B2B , you need to make one catalog as an public catalog , other wise product will not displayed. if you go at the backend there is shared catalog functionality choose click on right side of the grid you will see option to make it public catalog. Feb 19 '18 at 16:23
2

Here's a snippet form the Magento For B2B Commerce User Guide:

If Shared Catalog is enabled in the configuration, the original master catalog continues to be visible from the Admin, but only the “default” public shared catalog is visible from the storefront. In addition, custom catalogs can be created that are visible only to members of specific company accounts.

So, basically you need to:

1) Create a shared catalog,

2) Create a company, and

3) Assign that company to the shared catalog

This should get you where you want to be so you can see products again.


For the "default" shared catalog (basically, the one that guests are allowed to look at) you need to configure it to be a public catalog.

A public catalog...

Identifies the shared catalog that is available to all guest visitors and to logged-in customers who are not associated with a company. A “default” pubic shared catalog is created when Magento B2B is installed, but must be configured by the administrator. Only one public shared catalog can exist at a time.

To update the catalog details:

1) On the admin sidebar, hit catalog then, choose Shared Catalogs

2) On the actions dropdown select General Settings

3) Then change the type option to public

1
  • We have enabled the shared catalog, but it's visible only for logged in customers, how can we enable it to show for all users including guest users in the storefront?
    – sahana
    Feb 19 '19 at 8:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.