1

I have 2 websites with Magento 2.2.2 with luma theme. For one prefix and suffix works fine. For other, no prefix and suffix are rendering.

Who can explain me exactly where part of the code is used to generate the title I will try to debug it. Thanks a lot, guys

  • Please change the store view for other website and add your products and suffix from store - configuration – Purushotam Sharma Feb 17 '18 at 17:13
0

From what you described I think it's most likely scope issue with your configuration setting.

You can use php bin/magento config:show to see what value has been set for head_title_prefix and head_title_suffix

However if you want to look into the code for debug put a breakpoint in vendor/magento/module-theme/Model/Design/Config/DataProvider.php::getMeta()

  • Hi, Thanks for you help. With php bin/magento config:show I don't undestand why my prefix and suffix are empy design/head/default_title - What's Up design/head/title_prefix - design/head/title_suffix - design/head/default_description - Default Description design/head/default_keywords - design/head/includes - In catalog I can see my separator : catalog/seo/title_separator - - But in my backend configuration I can see the value : Page Title Prefix ok Page Title Suffix <ok So If the command configuration can't see it it's normal it wasn't apply. But why ? – Ludovik Dopierala Feb 18 '18 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.