0

Whenever I change less files in my current theme I get logged out from the backend.

  • I'm using server-side compilation
  • I'm using grunt with livereload.
  • I'm in developer mode.

Both of them seem to work fine in themselves apart from the part where I get logged out.

Any ideas why this might be happening every single time?

4
  • You can take a look a the following link related to session timeout magento.stackexchange.com/questions/101799/… – Ledian Hymetllari Feb 16 '18 at 22:23
  • Thanks @LedianHymetllari for the quick reply. I've already adjusted all the variables / configs related to session mentioned in that thread. It was the first one I found as well. I dont' get disconnected for hours if I don't make changes that require me to recompile styles. On the other side as soon as I edit a padding on my _extend.less file I get instant disconnection even if I've just logged in. – gabtzi Feb 16 '18 at 22:35
  • What commands are you running before you get logged out? – Ethan Yehuda Feb 16 '18 at 22:55
  • I'm just using grunt watch and uploading the new less file. My sequence is grunt exec; grunt less; grunt watch – gabtzi Feb 16 '18 at 23:00
0

These are separate features (admin session and less processor), so I suspect that your grunt configuration does something to the var folder/ clearing session database (memcache / redis..).

Check how are you storing session and make sure that your grunt command doesn't touch it.

1
  • I see, from what I could find session is in database and the grunt tasks are default as provided by magento. However I read somewhere that it could be because of signing static files option in configuration. I've set it to disabled and will test it out thoroughly today. So far it looks to be working as I haven't disconnected yet – gabtzi Feb 17 '18 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.