0

I'm trying to update Magento 2.1.8 to 2.2.2. After the update I get errors about block attributes on layouts.

1

Try to remove type and src_type (and maybe others) from elements of your layout files.

For example, I had to remove them from thesr layouts:

app/design/frontend/themevendor/themename/magento_theme/layout/default.xml
app/design/frontend/mytheme/base/magento_theme/layout/default_head_blocks.xml
1

You need to remove/change some of the attributes (error will tell you what is needed to be removed/changed). Xml validation has been updated with 2.2.x version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.