1

I have been struggling with a problem for few days now and am not bale to solve it.

I run Magento 2.2.2 on a Linux VPS with PHP7.1

First I developed site on a development domain dev.mydomain.com everything worked great cache was creaeted and served. When site was ready I cahnged domein name from dev. to www.mydomain.com this was an existing domain point to other directory first.

I changed domains in index.php (it is multistore) and changed in DB this is normal procedure I always do and it always works.

Now live site works and cache is created but pages do not load the cache. I really am puzzled what is causing this. I did all standard things flush cache, compile etc. Struggling if it is sever relate or Magento.

Anybody a clue on where to look?

Thanks, Maco

  • Have you check where all cache enable or nor? – Rakesh Jesadiya Feb 10 '18 at 10:34
  • Like I said, it is just a domain change nothing else was changed. Before domain name change it worked and after it stopped. – KooTjoo Feb 10 '18 at 10:37
  • Try running these commands if production mode is enabled skip this php bin/magento deploy:mode:set production php bin/magento setup:upgrade php bin/magento setup:di:compile php bin/magento cache:enable – Thiago Lima Feb 10 '18 at 11:50
  • Did all that no luck, still same issue. – KooTjoo Feb 10 '18 at 13:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.