0

I have an ecommerce website built on Magento (1.9.2.3). Last night I shifted it from localhost to online hosting (BigRock) - let's call this live server. The issue is that on live server Magento is not sending any mails. Instead it gives the following error:

Service Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Additionally, a 503 Service Temporarily Unavailable error was encountered while trying to use an ErrorDocument to handle the request.

The store is not in maintenance mode.

I am using SMTP Pro extension and it's self-test are running fine. On localhost, the same setup is working i.e. I can receive new order, invoice, shipment etc. mails.

I have checked the access logs on online hosting, nothing stands out. Have compared them to the logs on localhost, they both show same request and response sequence.

I have enabled logging in Magento. Got the following in exceptions.log:

https://pastebin.com/rch2BsrX

Following are the content of system.log:

https://pastebin.com/4F6wK35e

If I disable email communication in Magento (in Configuration > System > Mail Sending Settings) everything works fine, except obviously mail functionality is disabled.

I have checked file permissions as well, they are same as on localhost.

Cron settings are as per the guidelines. Though when I access cron.php from the browser it gives error 403.

There's an error_log file in the webroot directory. It says:

[10-Feb-2018 05:03:03 UTC] PHP Notice: Undefined index: SCRIPT_NAME in /cron.php on line 40 [10-Feb-2018 05:03:03 UTC] PHP Notice: Undefined index: SCRIPT_FILENAME in /cron.php on line 41

Right now, I am not sure where or what the issue is. I have recently begun with Magento development. Can really use some help.


Adding my comments here (since I don't have comment privileges as of now):

@Piyush: It's set to 30 seconds on both localhost and Web host

  • seems to be issue with your server configurations, check if there is any issue related to max_execution_time or other limits – Piyush Feb 10 '18 at 5:38
0

Solved the issue. Turns out live server was set to the wrong version of PHP. It was set to PHP 5.4. I changed it to PHP 5.6 and things were back to normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.