Magento 2.2 is allowing me to login to the backend, but as soon as I click on something it sends me back to the login form and shows the message

Visible section not found.

I don't see any errors in Apache's log, and there are no errors in any of Magento's var/log/*.log files.

I have manually removed Magento cache files. Also tried clearing the session table in the database and ran bin/magento setup:upgrade in verbose mode.

I have also run: bin/magento cache:flush and bin/magento cache:clean

What other steps can I take to troubleshoot this?

Update: I have found that this is caused by a module I used to help with the development process. However, it was basically just from turning modules on and off and testing each one. There was NO indication in any log file of the cause. Would still love to see suggestions on where I could have found this.

  • Clear your cache and try to login again. – Cyclonecode Feb 7 '18 at 16:57
  • @Cyclonecode my browser cache? I did that... and tried another browser, and had a colleague try from their machine. – user1988065 Feb 7 '18 at 17:54
  • No not the browser cache the magento cache =) You should be able to do this from the command line by going to your magento root directory and execute: php bin/magento cache:clean – Cyclonecode Feb 7 '18 at 17:58
  • @Cyclonecode yeah, did this too. I just updated my question to include that note. – user1988065 Feb 7 '18 at 18:09
  • 2
    @Cyclonecode I am not sure I can fully blame the module, but disabling it made this stop happening. MSP DevTools. This could have been something specific to my install though. – user1988065 Feb 12 '18 at 16:07

I struggled to solve this problem, too. But Solution was very easy in my case.

Go to magento_root/app/etc/ then open file env.php

Change below frontName xxxxxx with what you want

return array ( 'backend' => array ( 'frontName' => 'xxxxxx', ), .......

  • 3
    Somehow changing again admin FrontName , solve the problem. I think I had that issue after enabling MSP_DevTool like from comments above. – BartZalas Dec 30 '18 at 16:15
  • I have this issue after enabling MSP_DevTool, and changing frontName didn't help – TheKitMurkit May 20 '19 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.