I'm at a loss as to what to do next, I've reviewed all of the posts on the site and tried every solution, but still I am unable to see pagination of the products, the toolbar is simply not displaying?

Steps taken so far: 1. Upgraded the site from 1.7 to 1.9 (not working on 1.7 either, so thought an upgrade would resolve) 2. Added all appropriate code, based on the solutions on this site, to List.phtml, Catalog.xml 3. Tried recopying the original files from a fresh download. 4. Modified the pagination settings within the admin menu, from grid to list etc and played around with the settings, I get to see more products when amending, but still no toolbar displaying? 5. Added a 3rd party extension called Meanbee infinite scroll, to see if that would override the settings. But no change at all after enabling in the admin config menu?

The site address is sos-swim.co.uk.

I'm not a web developer and just trying to help out a friend.

Any suggestions would be great to point me in the right direction.

All the best Alan


1 Answer 1


Adding ?p=2 to the end of your url works fine, so that shows us that the pagination is active, it's just the block not displaying.

Infinite scroll extensions typically 'click' the pagination in the background, hence that one not working for you

Do you have this code in list.phtml?

<div class="toolbar-bottom">
    <?php echo $this->getToolbarHtml() ?>

Also, check settings such as 'is anchor' in the category settings in Magento admin - there's a chance you're targeting the wrong catalog_category handle in your catalog.xml.

  • Hey Ricky - yes code already added to the list.phtml and 'is anchor' set to yes in each category/sub category?
    – Lani Loo
    Feb 7, 2018 at 9:40
  • In that case, do you have <catalog_category_layered> in your catalog.xml? The toolbar should be contained within there. e.g. catalog/product/list/toolbar.phtml - can you verify the file and folder permissions are correct also? Feb 7, 2018 at 9:51
  • yes that's there also: <catalog_category_layered translate="label"> <label>Catalog Category (Anchor)</label>
    – Lani Loo
    Feb 7, 2018 at 10:01
  • also in terms of the file permissions, it's shared hosting and from what I can tell the file permissions are correct
    – Lani Loo
    Feb 7, 2018 at 10:08
  • 1
    I found this issue!!!! Someone had disabled one of the key themes within the Advanced menu, i enabled this and Pagination was visible again. Thanks for your help Ricky.
    – Lani Loo
    Feb 7, 2018 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.