0

I have installed the Advanced Reporting extension for Magento 2. When I enable it I am getting errors. I did the following commands:

php bin/magento setup:upgrade
php bin/magento setup:db-schema:upgrade
php bin/magento indexer:reindex
php bin/magento setup:static-content:deploy
php bin/magento cache:flush

On my site I'm getting the error:

Exception #0 (Magento\Framework\Execption\LocalException): Please upgrade database: Run: "bin/magento setup:upgrade" from the Magento root directory.

My terminal gives me the error:

[Zend_Db_Statement_Exception] SQLSTATE[HY000] General Error: 1419: You do not have SUPER privileges

and

[PDOException] SQLSTATE[HY000] General Error: 1419: You do not have SUPER privileges

0

You can fix it by setting the log_bin_trust_function_creators MySQL option to 1.

Visit this website for more info: https://dev.mysql.com/doc/refman/5.7/en/server-system-variables.html#sysvar_log_bin_trust_function_creators

You can set this up directly in MySQL client:

set global log_bin_trust_function_creators=1;

If you can't change this setting, speak to your hosting provider.

You can also try the following:

mysql -u USERNAME -p
set global log_bin_trust_function_creators=1;
  • I ran the command and then reran all the other commands and still get the same error – Matt Brown Jan 29 '18 at 15:42
  • What MySQL client are you using? – Greg Jan 29 '18 at 15:47
  • I am using MySQL 5.7 – Matt Brown Jan 29 '18 at 16:03
  • Are you using PhpMyAdmin? – Greg Jan 29 '18 at 16:08
  • No i have setup a local Db – Matt Brown Jan 29 '18 at 16:10
0

I found in my database that the data version was missing. I filled it in with same version as the version schema and then ran the install commands again, cleared the cache and the extension installed successfully with no errors.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.