4

I've installed a fresh copy of ce-1.9.0.1 with sample data for 1.9.0.0 for testing purposes.
I'm trying to perform a checkout as a logged in customer (by the way...where is the damn logout button?) and as a guest but I get stuck on the saveBilling action.
The call stops (firebug says the request was aborted) and I cannot continue the checkout.
I tried both "Ship to the same address" and "ship to a different address".

I narrowed it down to crashing when calling $quote->collectTotals().
I will investigate further but I'm curios if someone else is experiencing the same thing and, if so, how can I fix it?

1
  • I had similar issue even in Magneto 1.7 on the official demo site. When Firebug in Firefox was enabled, the checkout crashed after clicking "Continue" in "Billing Information" or "Shipping Information" (sorry but I don't remember details any more).
    – zitix
    May 20 '14 at 11:40
1

I think I found something.
By default the USPS shipping method is enabled (I think only in the sample data but not sure).
But I have no user and password for the gateway. It seams that this crashes the system. Disabling the shipping method solves the problem, or better yet, hides it. I think this might be a bug. From my point of view, if the credentials are not correct, the shopping method should not me shown.

3
  • Interesting detail, I fixed the same issue in Sellvana. And also with UPS. Conspiracy?!?
    – user4351
    May 20 '14 at 17:19
  • @Melvyn. Yeah...that's it.a conspiracy. But we cracked it, didn't we?
    – Marius
    May 20 '14 at 20:03
  • @Melvyn yes, but Magento can't melt steel beams. Mar 23 '15 at 18:18
0

I have tried to disable the shipping and USA module, while the checkout process still stopped at the shipping information step.

Then I tried to enable the php_soap extension in PHP, and it works.

So I thought that might be another way to solve the problem.

PS, the performance become untolerable in the checkout process. I am not sure if it is the soap extension that effect the performance.

1
  • Hmmm. This is strange. I had the php_soap extension enabled and I still had the error. I was able to fix it only by disabling the USPS shipping method.
    – Marius
    Jul 8 '14 at 8:31
0

I've got this issue too. After some investigation I appeared in Zend_Uri_Http in validateQuery method. On line "$status = @preg_match($pattern, $query);" Apache crashed. Issue in my case was a small ThreadStackSize of Apache mpm on Windows platform, it is 1Mb when Unix/Linux have 8Mb. So I added

<IfModule mpm_winnt_module>   
    ThreadStackSize 8388608
</IfModule>

to Apache config, and this solved this issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.