1

I upgraded from Magento CE 1.8.1 to 1.9.0.1 and now the FedEx and USPS shipping modules I had set up do NOT work, as in they do not show in the shipping step at checkout.

At first I thought it might be a Theme / Template issue since I am finding that virtually ALL of the Themes that I have tried, that worked fine with 1.8.1 have problems somewhere with 1.9.0.1 so I set it to the RWD Default theme that was part of the 1.9.0.1 Magento CE install, but it did not fix the shipping problems.

I was using the following in 1.8.1 with no problems:

Free Shipping FedEx USPS UPS

Now the only two I can get to work are UPS and Free Shipping. The UPS module is really not that great as it does not factor return accurate shipping values.

Any help would be appreciated. ( I have cleared the cache and have tried enabling / disabling the shipping options to no avail.)

2
  • I had the same issue on fresh installation of 1.9 + custom shipping method – tawfekov May 27 '14 at 17:14
  • Did you solve your issue? – zus Feb 14 '18 at 9:08
1

As of September the USPS API system has changed. This basically requires a few patches for Magento. Full information on the changes can be found at the following links.

  1. Magento Blog
  2. Magento Patch
  3. Webshopapps Blog

I suggest that you will have to download the patch from Magento and test that these shipping methods are now working.

0

I found this on a fresh install when I was missing the php-soap extension. The page would return me to the cart, and the following showed in the error logs:

PHP Fatal error: Class 'SoapClient' not found in /var/www/vhosts/xxxxxxxxxxxxx/app/code/core/Mage/Usa/Model/Shipping/Carrier/Fedex.php on line 134

yum install php-soap

and then

service httpd restart

This may, or may not be the issue you are facing?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.