1

In my Magento installation I have JQuery 1.10 already included but I need to have a newer version of it.

I added the latest version of JQery via the xml update tab in the cms page and I wrote my code in the content section of the cms page.

My code works but it breaks "the rest" of my javascript on that page, for example my language switcher does not work and the text in my search field disappeared.

Any idea how to solve that?

  • Without an error message, I can't really tell you how to solve this. I assume that your newer jQuery version might not run in NoConflict-Mode, and this is why it breaks the parts of your site that use prototype.js – simonthesorcerer Jan 23 '18 at 9:04
0

Jquery and prototype js conflicts with each other so while you are using jquery in your site you must put var $jq = jQuery.noConflict(); at the very bottom of your jquery lib or create a new file with this code and place/include just after your jquery library.

And use variable $jq instead of jQuery in your code to resolve any conflict with other magento js.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.