1

My Magento version is 2.1.4 and Mailchimp version is 1.0.25. The issue is, when I enable Mailchimp extension, the checkout page is not working properly. We are using Mageplaza's Onestepcheckout extension for checkout. On disabling Mailchimp, everything works fine. Firebug shows following error on checkout page:

Error: Script error for: campaigncatcher
http://requirejs.org/docs/errors.html#scripterror

Can someone tell me what could be the issue here?

Thanks in advance!

5
  • Also, when creating store at backend, showing following error in firebug: >>>>>>>> Error: Script error for: monkeyapikey requirejs.org/docs/errors.html#scripterror >>>>>>>> – Deeps Jan 23 '18 at 6:22
  • 1
    run php bin/magento setup:upgrade should resolve your issue. – Aman Alam Jan 23 '18 at 6:42
  • @AmanAlam Thanks for quick response. But upgrade command is already executed so many times, that didn't fix issue. :( – Deeps Jan 23 '18 at 8:40
  • Have you check campaigncatcher is exist in module please check ones – Aman Alam Jan 23 '18 at 9:47
  • you should get this file vendor/namespace/module/web/js/ folder – Aman Alam Jan 23 '18 at 9:48
1

Thanks to Aman for the clue.

I've fixed the issue by executing upgrade command first and then deploying content.

php bin/magento maintenance:enable 
php bin/magento setup:upgrade 
php setup:static-content:deploy (Deploy for each language of the store separately) 
php bin/magento maintenance:disable 
php -f bin/magento cache:flush

Hope this helps someone. Thank you!

1
  • Thanks. Totally forgot to flush. lol – Mohammed Joraid Jun 10 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.