7

I want to remove the captcha and its input field from the forgot password form and admin.

Magento 2 captcha

Please help me to remove that.

0

8 Answers 8

17

If you prefer to run commands instead of going to admin panel:

Disable admin login captcha

php bin/magento config:set admin/captcha/enable 0

Disable frontend captcha ( If form specific captcha is required then please check the Prince Patel's answer )

php bin/magento config:set customer/captcha/enable 0
7

Google reCaptcha is now default added into Magento version 2.4.x

To enable/disable reCaptcha for frontend forms:

Admin->Configuration->Security->Google reCAPTCHA Storefront

To enable/disable reCaptcha for admin forms:

Admin->Configuration->Security->Google reCAPTCHA Admin Panel

For normal captcha in the older version of Magento

To enable/disable captcha for frontend forms:

Admin->Configuration->Stores->Customers->Customer Configuration->CAPCTHA->Forms

To enable/disable captcha for admin forms:

Admin->Configuration->Stores->Advanced->Admin->CAPCTHA->Forms
1
  • "via terminal" 👎 Commented Nov 8, 2023 at 19:48
3

There are two commands to disable recaptcha in Magento 2.4.4:

  1. Disable reCAPTCHA for admin user forgot password form:
    bin/magento security:recaptcha:disable-for-user-forgot-password
    
  2. Disable reCAPTCHA for admin user login form:
    bin/magento security:recaptcha:disable-for-user-login
    
2

You can run these commands to disable it:

wget https://files.magerun.net/n98-magerun2.phar && chmod +x ./n98-magerun2.phar
alias n98="./n98-magerun2.phar"
n98 config:store:set msp_securitysuite_recaptcha/frontend/enabled 0
n98 config:store:set msp_securitysuite_recaptcha/backend/enabled 0
n98 config:store:set admin/captcha/enable 0
n98 config:store:set customer/captcha/enable 0
n98 config:store:set recaptcha/general/enabled 0
n98 s:upgrade
n98 c:flush
1

If you mean the Forget Password for the admin section, it is found under:

Stores => Settings => Configuration => Advanced => Admin

And Scroll down to CAPTCHA

1
  • "via terminal" 👎 Commented Nov 8, 2023 at 19:51
1

For magento 2.4.6 Just run following command bin/magento security:recaptcha:disable-for-user-login

1
0

To disable recaptcha totally on my dev computer I ended up with these entries in my env.php file.

The type_for's setting to null was what resolved the recaptcha issue for me, as Magento_ReCaptchaFrontendUi and similar only check if keys and type are set instead of checking an enabled config setting.

<?php
return [
    'system' => [
        'default' => [
            "admin" => [
                'captcha' => [
                    'enable' => 0
                ]
            ],
            "customer" => [
                'captcha' => [
                    'enable' => 0
                ]
            ],
            "recaptcha" => [
                'general' => [
                    'enabled' => 0
                ]
            ],
            "msp_securitysuite_recaptcha" => [
                'frontend' => [
                    'enabled' => 0
                ],
                'backend' => [
                    'enabled' => 0
                ]
            ],
            "aminvisiblecaptcha" => [
                'frontend' => [
                    'enabled' => 0,
                    'default_forms' => null
                ],
                'backend' => [
                    'enabled' => 0
                ],
                'advanced' => [
                    'enabled_captcha_for_guests_only' => 0
                ]
            ],
            'recaptcha_frontend' => [
                'type_for' => [
                    'customer_login' => null,
                    'customer_forgot_password' => null,
                    'customer_create' => null,
                    'customer_edit' => null,
                    'contact' => null,
                    'product_review' => null,
                    'newsletter' => null,
                    'sendfriend' => null
                ]
            ],
        ]
    ]
];
0

If Google captcha, use the following:

bin/magento config:set recaptcha_backend/type_for/user_login ""

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.