0

I'm getting this error:

    Uncaught Error: Class 'DOMDocument' not found in /home/hgfvhx/public_html/vendor/magento/framework/Config/Dom.php:384
Stack trace:
#0 /home/hgfvhx/public_html/vendor/magento/framework/Config/Dom.php(115): Magento\Framework\Config\Dom->_initDom('<?xml version="...')
#1 /home/hgfvhx/public_html/vendor/magento/framework/ObjectManager/Config/Reader/Dom.php(70): Magento\Framework\Config\Dom->__construct('<?xml version="...', Object(Magento\Framework\App\Arguments\ValidationState), Array, 'xsi:type', NULL)
#2 /home/hgfvhx/public_html/vendor/magento/framework/Config/Reader/Filesystem.php(149): Magento\Framework\ObjectManager\Config\Reader\Dom->_createConfigMerger('Magento\\Framewo...', '<?xml version="...')
#3 /home/hgfvhx/public_html/vendor/magento/framework/Config/Reader/Filesystem.php(130): Magento\Framework\Config\Reader\Filesystem->_readFiles(Object(Magento\Framework\Config\FileIterator))
#4 /home/hgfvhx/public_html/vendor/magento/framework/App/ObjectManagerFactory.php(275): Magento\Framework\Config\Reader\File in /home/hgfvhx/public_html/vendor/magento/framework/Config/Dom.php on line 384

PHP extensions:-

xmlreader:enabled

xmlrpc: enabled

xsl: enabled

dom: enabled

what the problem take all day searching no solutions worked :/.

0

Package php-dom is a virtual package.

Install the php-dom module on your system:

sudo apt-get install php-xml

If you are using 5.6 versions then go with this way:

sudo apt-get install php5.6-xml

And restart your server:

sudo service apache2 restart
|improve this answer|||||
  • I'm in shared hosting I can't install anything and also can't restart apache. + php-xml is enabled and dom enabled as I mentioned above – Mohamed Elkashef Jan 21 '18 at 19:44
  • @MohamedElkashef - Maybe issue occurs due to php version, have you discussed this matter with server team? – Pratik Oza Jan 21 '18 at 20:14
  • I already contacted them with chat they tried to help but didn't solve anything then they told me. that I need to call the technical teams. – Mohamed Elkashef Jan 21 '18 at 20:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.