0

I try to install extension Magento 2 SMTP.

https://www.mageplaza.com/magento-2-smtp/

So I downloaded the extension and upload FTP to folder: app/code/Mageplaza/magento-2-smtp-master

Then I run the SSH command:

wget https://getcomposer.org/composer.phar

php composer.phar require mageplaza/module-smtp

When I run this command I get error, below is screenshot. Anyone know how to solve it ?

enter image description here

2
  • can you run command ls -all to see if the ownership's are correct? – Greg Jan 19 '18 at 16:43
  • I run this command and please check photo: image.ibb.co/cfaODb/error2.png Is something wrong? – Sylvester Jan 19 '18 at 16:46
0

Try this in your terminal:

sudo chown -R user ~/.composer

Make sure you replace user with your current user

5
  • it looks like the rights are correct for the user from whom I run the commands. image.ibb.co/cfaODb/error2.png What do you think about it ? – Sylvester Jan 19 '18 at 16:51
  • type which composer in you terminal and tell me what you get – Greg Jan 19 '18 at 16:56
  • I run which composer but not get any information. ibb.co/cKdUKG – Sylvester Jan 19 '18 at 17:01
  • Did you manage to get it sorted? – Greg Jan 19 '18 at 20:19
  • I have refreshed the topic because I have a problem with running your command sudo chown -R user ~/.composer magento.stackexchange.com/questions/210233/… – Sylvester Jan 19 '18 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.