1

Buttons on left admin menu does not react on mouse actions.

The error in console says

TypeError: Formatter is not a constructor

I tried

setup:static-content:deploy 

but nothing happens.

  • Refer this link. – Pratik Oza Jan 19 '18 at 11:27
  • Try to change your environment, let's say developer to production and check if problem is solved – inrsaurabh Jan 19 '18 at 11:31
  • 1
    magento2.2 not support setup:static-content:deploy instead of you need to use setup:static-content:deploy -f – Monarch Jan 19 '18 at 11:55
  • @Jeremy, what console errors do you get? Would be worth if you added it to the question. – André Ferraz Jan 19 '18 at 11:55
1

Are you using Windows os?

If yes then may be issue related symlink file,

please follow the below steps to fix the same…

1)Remove everything, except .htaccess file from pub/static folder

2)Open up app/etc/di.xml find the path “Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink” and replace to “Magento\Framework\App\View\Asset\MaterializationStrategy\Copy”

Note: Remove entire files and folder under pub/static except .htaccess file.

after run

php bin/magento setup:static-content:deploy -f

or for old magento2 version

 php bin/magento setup:static-content:deploy

i got same issue that time i was follow bellow

link

.

 http://www.dckap.com/blog/magento-2-admin-links-not-working-in-windows/
1

Error shows because of magento admin not able to get the js files values.

Possible Solutions 1 :

1) go to app/etc/di.xml find the line

Magento\Framework\App\View\Asset\MaterializationStrategy\Symlink

and Replace it with

Magento\Framework\App\View\Asset\MaterializationStrategy\Copy

Possible Solutions 2 :

2) Goto Magento 2 root directory -> pub -> static and remove static folder and remove var/cache, var/composer_home, var/generation, var/page_cache, var/view_preprocessed

After that run below commands

  • php bin/magento setup:static-content:deploy

  • php bin/magento cache:clean

  • php bin/magento cache:flush

0

Run below commands ans check

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy
php bin/magento cache:clean
0

Ok, so based on the description I see the following as possible solutions.

  1. You have broken generated code. In Magento 2.2.* the generation folder under var does not exist anymore, it has been moved to root folder of the installation under the folder generated. Clear the contents of that folder.
  2. You don't have a record for dev/static/sign in the core_config_data table and if you do it's set to 1 instead of 0. If you don't use the MySQL query below.

You haven't provided much information can't assumed anything else.

INSERT INTO 'core_config_data' ('path', 'value') 
VALUES ('dev/static/sign', 0) 
ON DUPLICATE KEY UPDATE value = 0;
  1. You haven't cleared your browser cache.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.