0

I'm trying to debug magento 2.2.2 with xdebug via PhpStorm. When I'm trying to set points in index.php - it works perfectly, but when I'm going to debug some custom or core files Xdebug is not going through that files but if I using die() in those files it works.

It looks like it using php 5.6 instead of 7.0 for xdebug, but in phpstorm everything looks properly.

I'm using this settings:

http://joxi.ru/12ME989I4YoZG2 http://joxi.ru/gmvnBdBCxVEkjm http://joxi.ru/Vm6LBMBtx95GGA http://joxi.ru/GrqZ7E7tNjEXVm http://joxi.ru/Dr8ZBlBtk16G92

Please, help me to resolve this issue. Thanks

  • joxi.ru/v29aBEBfGnPER2 – Alkos Jan 17 '18 at 12:17
  • please upload these images to stack. your image hosting provider is not worksafe! – steros Jan 17 '18 at 12:23
0

You have to enable xdebug in your php.ini like this:

[XDebug]
xdebug.remote_enable = 1
xdebug.remote_autostart = 1

Make sure you have it enabled in php7.0 and not php5.6

I'm using nginx and php-fpm so on my computer they are located her:

/etc/php/7.0/fpm/php.ini
/etc/php/5.6/fpm/php.ini

Don't forget to restart php after you have done your changes

sudo service php7.0-fpm restart

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.