0

I have done everything I've found here and elsewhere:

  • All products are enabled
  • All products are In Stock with 1+ quantity
  • All products are set to Catalog, Search
  • I have reindexed multiple times, as well as tried reindexing via shell
  • I have cleared cache multiple times
  • All products are in active categories

For example, in the admin panel, a specific category shows 662 products, but on the frontend it only shows 337. It's becoming annoying because some filterable attributes only show a few items when used, despite there being many more.

The items are there when searched for using advanced search. They are not there when using attributes to filter for them.

  • 1
    Check the website, storeview product config and also the product attributes – PЯINCƏ Jan 16 '18 at 23:00
  • Do you have multiple stores or websites? – Yiorgos Moschovitis Jan 16 '18 at 23:14
  • One single store/website. – taskle Jan 16 '18 at 23:23
  • Also, all the attributes are there and show on the product page. The filter just won’t filter them by it. – taskle Jan 16 '18 at 23:27
  • Just a guess, but usually merchants are not really willing to create 662+ products by hand - so I would assume these have been imported? In that case - did you try to save the products again from backend as this sounds a lot like a broken import script to me... – Christoph Farnleitner Jan 17 '18 at 0:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.