0

In my admin, my catalog configuration page is completely blank. I have not edited any of the code for this page. I do have a custom frontend theme installed, however.

I have already flushed set the caches under System > Cache Management, reset browser cache, and checked the admin page in question in another browser.

I am using Magento 2.2.1.

enter image description here

2
  • Refer this link to enable error reporting in Magento2.
    – Pratik Oza
    Commented Jan 11, 2018 at 19:09
  • Looks like an issue with one of the system.xml files in your instance most likley a 3rd party extension / theme i would recommend disabling all extensions and enabling 1 by one to determain which one is causing the issue or to save time you could edit the app/bootstrap.php and find #ini_set('display_errors', 1); and remove the # save and upload this should then display the errors on the page making easier to debug Commented Aug 30, 2019 at 7:35

2 Answers 2

0

I would try:

php bin/magento maintenance:enable

delete everything in the var folder except .htaccess

php bin/magento setup:upgrade
php bin/magento setup:static-content:deploy
php bin/magento cache:clean
php bin/magento cache:flush
php bin/magento setup:di:compile
php bin/magento maintenance:disable
php bin/magento index:reindex
0

the solution is

chmod -R 777 /path/xxx.com/public_html/generated/code/Magento/Catalog

how to find solution is

first,go to see /var/log/system.log ,you will see something about "main.CRITICAL: Can't create directory",which means permission problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.